Request has expired. Timestamp date - Solved

Get answers to your installation and setup questions.
lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Request has expired. Timestamp date - Solved

Post by lin » Sun Mar 13, 2016 7:19 am

Any way of permanently fixing this? I've tried Amazon Time Offset > 60, 120, -120, -60, 480 to no avail. I see no time displayed on my website. Just the date. Clocks go ahead tonight at 2:00 AM; seems they already reset there's.
Last edited by lin on Thu Mar 17, 2016 7:33 am, edited 1 time in total.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Sun Mar 13, 2016 8:03 am

What's the URL to the site?
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Sun Mar 13, 2016 8:48 am

Sorry, I think it's my problem. I thought it was something coincidental to do with our stupid daylight time savings changing tonight, but I just noticed the hardware failed on one of their servers last night so they pushed everything to a new server from a backup. They most likely missed a few files or the dns time difference between new and old server need time to complete. Thanks http://alinux.pw
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Sun Mar 13, 2016 12:38 pm

It looks to me like the offset time should be set to 244.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Mon Mar 14, 2016 5:09 am

Thanks, I tried it, but still no change. I'm wondering if the Amazon API port is being blocked on the new server. Would you know which port it uses. I read this "The AWS CLI makes API calls to services over HTTPS. Outbound connections on TCP port 443 must be enabled in order to perform calls."

I can't find anything about other port(s) that might need to be open. So I'm hoping 443 is the correct one?
-
Update: that port does appear to be OPEN; perhaps some other port the script uses?
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Mon Mar 14, 2016 8:21 am

It's got nothing to do with ports. Amazon servers have their internal time set, as with any server. If there is a conflict between their servers and yours, the error message is displayed. You have to be within 15 minutes of whatever time they are (and yes, different timezones are accounted for).

When I go to your site, I see the error message display the timestamp date as "2016-03-14T09:09:33.000Z." when it's 3:13pm my time. The timestamp is:

2016-3-14 (date)
T09:09:33.000z (9:09 and 33 seconds AM)

This works out to 6 hours, 4 minutes behind me. 6 x 60 = 240, plus 4 = a total offset of 244 minutes.

What I'd like to see is how the timestamp display compares to my time when you enter 244 as the offset.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Mon Mar 14, 2016 10:26 am

True. Doesn't look like a port issue now.

Their computer time $date: Mon Mar 14 07:07:59 EDT 2016
PHP alinux.pw Time: Mon Mar 14 13:12:29.000Z with 124 Amazon Time Offset to match my timezone here at home America/New York.

I'll set it to 244 now; you can take a look when you get a chance. Maybe I'll just fiddle with different numbers until
it clicks, or, their computer time is wrong cause 07:07:59 EDT time is 13:12 my local NY time. Seems far off since it says the Server IP is Georgia, Atlanta same timezone as New York.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Mon Mar 14, 2016 2:05 pm

It's still showing a four-hour delay (240 minutes). Is the offset still at 244?
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Mon Mar 14, 2016 4:24 pm

I had it set back to Zero, it's now 244.

One other thing I'm noticing now; installing the program to a test folder; it won't even SAVE the KEYS now; just shoots my back to the Login screen. That never happen before the server change so I'm thinking it's a permissions problem or they don't have ioncube library installed. I tried setting some main folders to 775; 777; in case it wasn't saving something it needed. But still just shoots me to the Login screen (on a new install, that is). I'll frig with it later on. In the meantime my Host wants my Login credentials to fiddle with it. I was hoping to get the Test install up and running for them to play with. It was a good thing I tried the Test; else I'd not known it's not evening installing now. Lol.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Tue Mar 15, 2016 2:46 am

Checking it just now, it's only two hours off. I wonder if adding another 120 to the 244 will finally catch it up (364).

If you're copying the entire program elsewhere and getting bounced back to the login when you try to change a setting, go into the /aom directory folder and change the permissions for the cfg.saved.php file to 777 (ignore the numbered versions, they're just backups). That usually does it.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Tue Mar 15, 2016 6:55 am

Host says:
Hello lin,

I conducted a detailed investigation and found out that main cause of the error is that this particular script is meant to be executed in UTC timezone only. The only way for a user to change default server timezone (EDT) for executable PHP scripts is to add a corresponding code to php.ini. As I see timezone is already set to "America/New_York" and the php page proves it.

While browsing Amazon forums for a clue I found this article: https://forums.aws.amazon.com/message.j ... eID=142164 People on the forum say that running such script in any time zone but UTC will cause "Request has expired." error. Further investigation led me to stackoverflow forum http://stackoverflow.com/questions/1235 ... tamp-issue where it was suggested to modify the script by supplying correct "dateTime" object values to its core files. Unfortunately, I do not know much about this script as it was not developed by our company and I cannot really help you with this matter.

I assume the script in question is not processed correctly in PHP timezone. Instead it runs in default MySQL timezone, that is also EDT, or in any other way bypassing correct UTC PHP timezone settings. If my assumption is correct, this error cannot be fixed since it is impossible to change default MySQL server timezone on shared servers.

I recommend you contacting the developer of this script to clarify if there is any other way to make the script process in correct timezone specified in PHP settings. If there is anything else we should do from our side except for changing default MySQL timezone, please let us know.

We are looking forward to hearing from you.
-

I say:
Hey pretty darn thoughtful of them to have gone through all the trouble when this wasn't even their software. So I thank them for trying.
Last edited by lin on Mon Mar 28, 2016 10:51 am, edited 1 time in total.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Tue Mar 15, 2016 6:58 am

mcarp555 wrote:Checking it just now, it's only two hours off. I wonder if adding another 120 to the 244 will finally catch it up (364).

If you're copying the entire program elsewhere and getting bounced back to the login when you try to change a setting, go into the /aom directory folder and change the permissions for the cfg.saved.php file to 777 (ignore the numbered versions, they're just backups). That usually does it.
-
You are the main man! 364 does the trick and thanks for the 777 on cfg.xx; I'm sure that will also work. Thank you very much mcarp555!!
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

mcarp555
Admin
Admin
Posts: 4088
Joined: Thu Sep 14, 2006 5:19 pm
Location: United Kingdom
Contact:

Re: Request has expired. Timestamp date

Post by mcarp555 » Tue Mar 15, 2016 1:44 pm

Hah! I knew we'd get there in the end! Sorry it took so long.

BTW, AOM doe not use MySQL, but flat files instead. Not that it matters in the long run. :wink:
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Tue Mar 15, 2016 2:58 pm

Yeah, funny how will tear down a website 10x, rebuild, Search endlessly, etc.. when only 3 numbers were all that's needed rite in front of us upon entering the Control Admin Panel. Lol :-)

The Associate-o-matic control panel is incredibly awesome and powerful once you start to learn how to work with it. You did an amazing job with it. Loaded with tons of tailoring features. Thanks again!
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

lin
Experience Level 1
Experience Level 1
Posts: 18
Joined: Mon Mar 07, 2016 2:06 pm

Re: Request has expired. Timestamp date

Post by lin » Wed Mar 16, 2016 3:45 am

It happen again this morning. Maybe my Host set a new computer time as I noticed after I ssh in the time was set to -500 EST New York time, same as PHP. So I tried 480 which brought it to NY time but skew didn't leave then I noticed it was a day ahead so I set it again to today's date: local server time New York -1430; working so far. Happy again :D
-
Update: Today March 17 it was a day behind. Server time is still NY time so I tried setting to Zero and it worked. Hopefully the last time with this issue. FTR: Notably it was all caused by my Hosting service and not associate-o-matic.

Update: Today March 20 No issues since the last time. Still set to default '0'.
Last edited by lin on Sun Mar 20, 2016 11:39 am, edited 3 times in total.
Associate-O-Matic is changing. For the better. 8)

Please CLICK HERE for our important announcement.

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests